Supported Third Party Software

From the makers of InspIRCd.
Jump to: navigation, search

The following pieces of third party software are currently known to work with InspIRCd (some require modules, which can be found on our site, in our Git repository or in the product's tarball):

Anope IRC Services

To use Anope with InspIRCd you will version 1.7.18 of Anope for InspIRCd 1.1 or above, or 1.7.12 and above for InspIRCd 1.0 or Anope 1.8.3, 1.9.0 or above for InspIRCd 1.2. Everything is supported in the current version of the module. The Anope module is included in Anope itself, and no other module should currently be used for InspIRCd.

Blitzed Open Proxy Monitor

To use BOPM with InspIRCd you must be running InspIRCd 1.0 Alpha 12 or greater and BOPM 3.x or above. No extra modules are required but specific configuration is needed.

Atheme IRC Services

To use Atheme you need the stable version of 4.0.1 (or newer), available from http://www.atheme.net/, and InspIRCd 1.0 beta 6 or above. InspIRCd 1.2.x is supported and preferred. The modules required for InspIRCd are included in Atheme as inspircd10.so and inspircd11.so. Atheme 4.0.1 will also work with InspIRCd 1.2 with the inspircd12.so module, but if you do use InspIRCd 1.2 and Atheme, it is highly recommended to use Atheme 5.0.1 as it has many bug fixes and many more features.

Denora IRC Statistics

To use Denora with InspIRCd, version 1.4.0 (or newer) available from http://www.denorastats.org. and InspIRCd 1.1 or above. The modules required are included with Denora.

FishBot

FishBot is a server-based IRC bot for Asuka (a patchset for IRCu). This build of FishBot has been ported to InspIRCd by LBR and works with the InspIRCd 1.1 releases.

Ecks

Ecks is an undernet-like services package written in Java. It supports InspIRCd 'out of the box'. for more information please see the website.

Other Software

If you find other software which works with InspIRCd please let us know and provide information on how it is done, so that we can update this list.