System Requirements

From the makers of InspIRCd.
Jump to: navigation, search

Mandatory software

To compile and run InspIRCd, the following software and hardware is recommended:

  • An operating system listed on our list of Supported Operating Systems
  • GCC 3.x or above compiler
  • Perl 5.8 or above for configure and launcher scripts
  • A modern, up-to-date system with at least 300mb RAM and a 750mhz CPU if you intend to run other programs too (unless you're a total cheapskate, this should not be an issue)
  • At least 85mb of free disk space to build InspIRCd and install it, more during runtime depending on how much logging you set your IRCd to do.


Notes
It is possible to get InspIRCd running on lower spec systems than listed here, however this is unsupported. If you are running on an ancient system, we will not be able to assist you if you have problems.

When we say gcc 2.x will not work, we mean it. There won't be any compatibility for 2.x now or in the future as it is no longer maintained by the GCC team and we can't get support for it! This means all you FreeBSD 4 users who are unwilling or unable to upgrade from your OS (We should remind you that it is now 3 years out of date!) will have to upgrade gcc to version 3, and upgrade Perl. Both of these can be done in a 'slotted' manner, alongside your current gcc and Perl, without breaking anything.

Before anyone says "but other IRCds compile with my ancient gcc ...", remember: those IRCds aren't written in C++, they're written in C, and proper C++ support in gcc only really became usable at the 3.0 release.

Optional software

Modules in the src/modules/extra/ directory require extra software to be properly compiled and ran. The software can be found in the following subsections.

SSL

InspIRCd offers two types of SSL implementations: GnuTLS (recommended) and OpenSSL

To compile either of these modules for InspIRCd, you must have the binaries and development packages for your selected type of SSL.

NOTE: If you are using FreeBSD and you would like to use OpenSSL, you *MUST* install openssl from the ports tree as the openssl that comes built-in to the system does not use pkgconfig which is required for InspIRCd.

Debian/Ubuntu users, install the following packages (for GnuTLS):

  • libgnutls-dev
  • gnutls-bin
  • pkg-config

Or for OpenSSL:

  • openssl
  • openssl-dev
  • pkg-config

Fedora/CentOS/etc users, install the following packages (for GnuTLS):

  • gnutls
  • gnutls-devel
  • gnutls-utils
  • pkgconfig

Or for OpenSSL:

  • openssl
  • openssl-devel
  • pkgconfig

Regex

InspIRCd offers various types of Regex engines to be used. Each engine has dependencies on certain software.

The GLOB regex engine is available on all platforms and has no dependencies.

The POSIX regex engine is not available to Windows platforms, and has no other dependencies.

The PCRE engine requires the source libraries to build against. Debian/Ubuntu users can install libpcre3-dev and it's dependencies with Apt. Fedora/CentOS/etc users can install pcre and pcre-devel packages with Yum.

The TRE engine requires the source libraries to build against. Debian/Ubuntu users can install libtre4 and libtre4-dev with Apt. Fedora/CentOS/etc users can install tre and tre-devel with Yum.