Talk:Supported Operating Systems

From the makers of InspIRCd.
Jump to: navigation, search

FreeBSD 7.x Support

I got InspIRCd 1.1.16 compiled and running on FreeBSD 7.0-PRERELEASE. I know 7.x isn't a release yet, but it is in the -STABLE branch. FreeBSD 7.x should be added to the article.

The InspIRCd 1.1.16 configure script didn't detect the base system OpenSSL. I DID NOT try installing the security/openssl/ port. The configure script detects GNUTLS using the security/gnutls/ port perfectly fine.

The version of InspIRCd in the FreeBSD ports database is using an old version, v1.1.8. So the article should recommend installing from the source downloaded from www.inspircd.org, NOT using the FreeBSD ports collection.