This site is deprecated; docs have moved to!

Coding Guidelines

From the makers of InspIRCd.
Revision as of 17:53, 30 November 2006 by Brain (Talk | contribs)

Jump to: navigation, search

InspIRCd Coding Guidelines

The following are a set of guidelines for writing patches to InspIRCd, or for creating modules for distribution with the official package. These guidelines were written a time after InspIRCd development started, and so not all code yet follows these. This will be rectified with time.


Multi Line

Multiple line comments should follow the C-style comment, for example:

 * This is a multiple line comment, huzzah..

Single Line

Single line comments should also be in the C style, for example:

/* This is a boring one-line comment */

Doxygen commenting

If you wish your comment to show in doxygen, the comment should be directly above the item you are documenting (a class, function, enum, etc) and the first line should be "/**". For example:

/** This is a doxygen multiline comment.
 * Description of thingymebob here.

The first line after the "**" is used as the short description of the item (up to the full stop) and everything afterwards as the detailed description.


Tabs. Tabs. ONLY TABS. Use a single tab for each level of indentation, for example:

int main()
<tab>if (condition)


Always put a space in between a keyword like if/while and the condition, for example:

if (foo == bar)


if(foo == bar)


Always put braces opening and closing blocks on separate lines, see the identation example. For example, place braces like this:

if (apples == "green")
        cout << "Apples are green" << endl;

and not:

if (apples == "green") {
        cout << "Apples are green" << endl;

The one exception to this is if you are declaring a class method which is only one line long, in that case the following is acceptable in most cases:

class foo : public bar
        foo() { }
        getrandomfoo() { return rand(); }


Where possible, use templates rather than #defines. Avoid use of RTTI.


Structs should be declared in the following fashion:

struct BodyPartBasket
        int arms;
        int legs;
        int scrotal_sacs;

and not like this:

typedef struct
        int arms;
        int legs;
        int scrotal_sacs;
} BodyPartBasket;

The second way is not required in C++ to be able to do this:

BodyPartBasket mybasket;

Plus, placing the name at the bottom of the declaration makes readability more difficult (as you have to scroll down to the bottom of the struct to find its name).